This project has moved and is read-only. For the latest updates, please go here.

Fails to run #2

Jun 7, 2016 at 2:37 PM
Following the above i asked someone else to install it.
The 'compile' works fine but when he runs he gets-
"'C:\SwiftForWindows\My' is not recognized as an internal or external command,
operable program or batch file."

How can it be solved?
Developer
Jun 18, 2016 at 1:13 AM
Edited Jun 18, 2016 at 1:14 AM
See issue#5
Sep 6, 2016 at 7:35 PM
Edited Sep 6, 2016 at 9:23 PM
I also had an issue like this. I renamed that directory and tried to use one without a space in it. It remade the other one when I closed and reran it and it proceeded to work. o.O

By the way, I have the English language version of Windows 10.

The other problem for me was the fact that my installation of Visual Studio failed to include the vcvarsall.bat file. The fix for which I found here:

http://stackoverflow.com/questions/33323172/vcvarsall-bat-needed-for-python-to-compile-missing-from-visual-studio-2015-v-1

Basically with this picture, need the highlighted checkbox, although in my frustration I proceeded to install everything:
http://i.stack.imgur.com/J1aet.png

I had to use the full Microsoft professional installation (https://www.visualstudio.com/post-download-vs?sku=pro&clcid=0x409&downloadrename=true) as opposed to any other pared down installation to get any access to this menu, and then follow it with the swiftforwindows installation. Just using the MS installation without adding those checkboxes was NOT enough to get past this issue. I tried that.